ASA-2019-00217 – GitLab: Divulgação de informações por discrepância de tempo


For the English version of this alert, click here.

Allele Security Alert

ASA-2019-00217

Identificador(es)

ASA-2019-00217, CVE-2019-10114

Título

Divulgação de informações por discrepância de tempo

Fabricante(s)

GitLab

Produto(s)

GitLab Community Edition (CE)
GitLab Enterprise Edition (EE)

Versão(ões) afetada(s)

GitLab CE/EE 11.9 e posterior

Versão(ões) corrigida(s)

GitLab Community Edition (CE) e GitLab Enterprise Edition (EE) 11.9.4
GitLab Community Edition (CE) e GitLab Enterprise Edition (EE) 11.8.6
GitLab Community Edition (CE) e GitLab Enterprise Edition (EE) 11.7.10

Prova de conceito

Desconhecido

Descrição

Durante o processo de autenticação do OAuth, o aplicativo tenta validar um parâmetro de maneira insegura, potencialmente expondo os dados.

Detalhes técnicos

Desconhecido

Créditos

Recurity

Referência(s)

GitLab Security Release: 11.9.4, 11.8.6 e 11.7.10
https://about.gitlab.com/2019/04/01/security-release-gitlab-11-dot-9-dot-4-released/

CVE-2019-10114
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10114

CVE-2019-10114
https://nvd.nist.gov/vuln/detail/CVE-2019-10114

Se encontrou algum erro neste alerta ou deseja uma análise compreensiva, entre em contato.

Última modificação: 14 agosto 2019

Não somos responsáveis por qualquer perda de dados, corrupção de dispositivos ou qualquer outro tipo de problema devido ao uso de qualquer informação mencionada em nossos alertas de segurança.