ASA-2019-00227 – Symfony: Verifica se os IDs de serviço são válidos


For the English version of this alert, click here.

Allele Security Alert

ASA-2019-00227

Identificador(es)

ASA-2019-00227, CVE-2019-10910

Título

Verifica se os IDs de serviço são válidos

Fabricante(s)

Sensio Labs

Produto(s)

Symfony

Versão(ões) afetada(s)

Symfony 2.7.0 anterior à 2.7.50
Symfony 2.8.0 anterior à 2.8.49
Symfony 3.4.0 anterior à 3.4.25
Symfony 4.1.0 anterior à 4.1.11
Symfony 4.2.0 anterior à 4.2.6

Versão(ões) corrigida(s)

Symfony 2.7.51
Symfony 2.8.50
Symfony 3.4.26
Symfony 4.1.12
Symfony 4.2.7

Prova de conceito

Desconhecido

Descrição

Os IDs de serviço derivados da entrada do usuário não filtrada podem resultar na execução de qualquer código arbitrário, resultando na possível execução remota de código.

Detalhes técnicos

Desconhecido

Créditos

Nicolas Grekas

Referência(s)

CVE-2019-10910: Check service IDs are valid (Symfony Blog)
https://symfony.com/blog/cve-2019-10910-check-service-ids-are-valid

Drupal core – Moderately critical – Multiple Vulnerabilities – SA-CORE-2019-005
https://www.drupal.org/sa-core-2019-005

CVE-2019-10910
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10910

CVE-2019-10910
https://nvd.nist.gov/vuln/detail/CVE-2019-10910

Se encontrou algum erro neste alerta ou deseja uma análise compreensiva, entre em contato.

Última modificação: 27 abril 2019

Não somos responsáveis por qualquer perda de dados, corrupção de dispositivos ou qualquer outro tipo de problema devido ao uso de qualquer informação mencionada em nossos alertas de segurança.